EXPDTA, EXPSPL and IMPDTA fail after 3.7 upgrade

FAQs and general information.
Support
Site Admin
Posts: 390
Joined: 03/12/04 02:12:52 PM

EXPDTA, EXPSPL and IMPDTA fail after 3.7 upgrade

Postby Support » 02/08/10 03:12:00 PM

<p>The EXPDTA, EXPSPL and IMPDTA no longer function after upgrading to 3.7. The Java error is most likely java.lang.UnsupportedClassVersionError </p><p>The EXPDTA, EXPSPL and IMPDTA commands all require Java 1.5 or higher. Previously required Java 1.4</p><p>The first thing to do is check to see if any newer versions of Java are installed on the iSeries. It's possible that a newer version of Java is installed but not default version(To view the default version of Java use command RUNJVA CLASS(*VERSION) ). Use the command:</p><p> GO MENU(LICPGM) - Select option 10 Look for Licensed Program 5722JV1. </p><p>Here is an example of what you might see. </p> <blockquote>5722JV1 *COMPATIBLE Java Developer Kit 1.3
5722JV1 *COMPATIBLE Java Developer Kit 1.4
5722JV1 *COMPATIBLE Java Developer Kit 5.0
5722JV1 *COMPATIBLE J2SE 5.0 32 bit
5761JV1 *COMPATIBLE Java Developer Kit 6
5761JV1 *COMPATIBLE Java SE 6 32 bit
5761JV1 *COMPATIBLE Java SE 6 64 bit
</blockquote> If there is a higher version installed you have 2 options.

1). Specify the Java version on the Surveyor command SURVEYOR/EXPDTA JAVAVER(1.5)
2). Change the default Java version on the iSeries. Edit file /QIBM/UserData/Java400/SystemDefault.properties (You can use Surveyor to do this). Specify the<b> java.version</b> property:

<blockquote>java.version=1.5</blockquote>
After saving the file you will have to change the CCSID to 1252
<blockquote>CHGATR OBJ('/QIBM/UserData/Java400/SystemDefault.properties') ATR(*CCSID) VALUE(1252)</blockquote><p>If there is not a higher version installed, either install one or downgrade to Surveyor 3.6
<a href="http://www.linomasoftware.com/phpBB2/viewtopic.php?t=372">Downgrade to 3.6</a>
</p>

Return to “Surveyor/400”

Who is online

Users browsing this forum: No registered users and 5 guests

cron